PCLOS: カーネル更新で X が起動できなくなった件

一週間ほど前に Twitter で呟いた件(及びその続き)です。

私は PCLinuxOS ではカーネルは LTS な 4.14 系を使っています。今月初めに 4.14.32 がリポジトリに投入されたので、それまで使っていた 4.14.26 から更新しました。

ところが更新後の再起動時の dkms による nVIDIA のドライバーのカーネルモジュールの作成が失敗して X が起動できなくなるという問題が発生しました。(グラボは GTX 960)
さらに前版の 4.14.26 で起動しても何故か X の起動に失敗するという状況に陥ってしまいました。

drakx11 でドライバーを nouveau に変更しても何故か X がエラーを吐いて起動できません。それではとカーネルを 4.15.15 に変更しても、やはり X を起動できません。

そこでカーネルを 4.9.92 に変更してみたところ、やっと X が起動できるようになりました。nVIDIA のドライバーにしても問題は発生しませんでした。

ここ数日はこの環境で使っていたのですが、このままでは 4.14 以降のカーネルがこの先も使用できない可能性が高いので、別にパーティションを新たに切って検証を行ってみました。

  • pclinuxos64-kde5-2017.11 を用いて新規インストール
  • 最新状態へ更新(カーネルも同時に 4.14.32 へ更新)
  • 再起動
  • nVIDIA のドライバーのカーネルモジュールの作成に成功して無事に起動

ということで、4.14.32 で問題なく起動できることが確認できました。

そこでこの検証用の環境を addlocale を用いて日本語化した上で、mylivecd で ISO イメージを作成しました。そしてその ISO イメージを用いてメイン環境の再インストールを敢行しました。結果、現在は無事に 4.14.32 で使用できています(^_^)

問題の発生したメイン環境は昨年の7月に新規インストールしたのを更新し続けてきたものでしたので、何かしら色々と「ゴミ」が有って、それが冒頭の X の起動失敗に繋がったのかもしれません。

inxi -Gxx


【4月14日 追記】

nVIDIA のドライバー更新で問題が再発しました。

【4月16日 追記】

再び X が起動できなくなった件(解決)

PCLinuxOS | comments (2) | -

コメント

sono1962 | 2018/04/10 02:10 PM
どうやら皆同じ状況なんですね(´・ω・`)。
我が家ではxorg.confを削除、再起動でドライバnouveau(xorg.confで確認)で800x600でX起動w。
その後解像度だけdrakconfにて1920x1080に変更してその後問題は出ていません。
オンボグラフィックのままだったらnouveauはクラッシュして使えなかったので恐らく詰んでいたと思われます(;・∀・)。
我が家ではカーネル4.9.??でもビルドエラーで駄目でした。
起動の度にビルド失敗し時間がかかるので現在はプロプラドライバは全て削除しました。
グラボはGT520です。
tomcat | 2018/04/10 02:39 PM
> xorg.confを削除

あっ、その手が有ったか。試してみれば良かった。完全に失念していました(^_^;)

> 我が家ではカーネル4.9.??でもビルドエラーで駄目でした

ここら辺りはグラボの違いにもよるのかなぁ?

> 起動の度にビルド失敗し時間がかかるので現在はプロプラドライバは全て削除

当方ではリポジトリの nVIDIA ドライバーが更新された際、インストール後に再起動もログアウトも不可になって、CTRL+ALT+Back でログイン画面に抜ける必要があります(毎回)

コメント フォーム